Instalar PHPUnit en Mountain lion con MAMP

Uso MAMP y estaba tratando de instalar PHPUnit.

Para hacerlo hay que ejecutar las siguientes lineas en el terminal:

$ pear channel-discover pear.phpunit.de
$ pear install phpunit/PHPUnit

El problema era que me daba el siguiente error: 

$ pear
-bash: pear: command not found

La solución es simple, hay que ver que versión de php se está utilizando

$ which php

La respuesta fue:

/usr/bin/php

NO ESTOY USANDO LA VERSION DE PHP DE MAMP!

Para modificarlo hay que ejecutar lo siguiente:

$ echo "export PATH=/Applications/MAMP/bin/php/php5.4.4/bin:$PATH" >> ~/.profile

Donde php5.4.4 es la version de php que esta usando MAMP.

Luego hay que reiniciar la sesión del terminal y escribir nuevamente.

$ which php

la respuesta debería ser

/Applications/MAMP/bin/php/php5.4.4/bin/php

ahora preguntamos por la version de pear

$ which pear

Respuesta:

/Applications/MAMP/bin/php/php5.4.4/bin/pear

Ahora si que podemos instalar phpUnit

Primero ejecutamos

$ sudo pear channel-discover pear.phpunit.de

Nos pedirá la contraseña de sesión y luego irá describiendo el proceso de instalación de la siguiente forma:

luego ejecutamos:

$ sudo pear install phpunit/PHPUnit

Y el retorno en el terminal debería ser algo así:

¡LISTO!, PHPUnit instalado.

Esta entrada fue publicada en Programación y etiquetada , , , . Guarda el enlace permanente.

Deja un comentario