Cambiar la versión de PHP utilizada en el terminal por la de MAMP

Primero, debemos determinar que versión de PHP está corriendo en MAMP y luego su ubicación. En éste caso la versión de PHP es la 5.4.10 y está ubicada en Applications/mamp/bin/php/php5.4.10/bin

Para saber que versión es la que estamos utilizando por defecto en el terminal debemos escribir

which php

a lo que el terminal responde

/usr/bin/php

Para cambiarla, debemos crear un archivo llamado .profile en la carpeta de usuario /usuarios/nombredeusuario y escribir la siguiente línea

PATH=Applications/mamp/bin/php/php5.4.10/bin:$PATH

Lo anterior, podemos hacerlo desde el mismo terminal con vi de la siguiente forma:

Estando en la carpeta del usuario ejecutamos vi .profile

Luego, presionamos la tecla i para insertar, escribimos la línea y finalmente ESC :wq

En el terminal ejecutar

source .profile

y para asegurarnos de que estamos usando la version de mamp nuevamente ejecutamos

which php

nueva versión de PHP

Esta entrada fue publicada en Programación y etiquetada , , , . Guarda el enlace permanente.

Deja un comentario